Results 1 to 2 of 2

Thread: Anyone experience problems with USB hard drives?

  1. #1

    Question Anyone experience problems with USB hard drives?

    I'm having a strange problem on my Windows 7 64bit system with one particular USB hard drive. I have been using it for my backups on a regular basis for the past year and recently it started giving me problems.

    When I connect it to the system, after a variable amount of time it will stop responding and generate a "The driver detected a controller error" error in the system log. After which I get a whole bunch of ntfs warnings of "The system failed to flush data to the transaction log. Corruption may occur." because it can no longer read or write to the ntfs drive.

    This only seems to happen with this one drive, my other USB based devices are all working fine. I have tried different ports with the same result. If I plug the usb HD into another Windows 7 64bit machine, it works fine, will do a completed checkdisk /r to search the entire drive for bad sectors and comes up with no errors. So the drive works fine on another system.

    Anyone seen this before? I even tried uninstalling all my USB drivers from Windows, deleting the infcache.1 USB driver cache and starting over, but that did not fix the problem either. The system is running cool and stable (both CPU and memory) so not sure what is going on.


  2. #2
    BOINC Gypsy ChertseyAl's Avatar
    Join Date
    Aug 2008
    London, Englandshire
    Not that this will necessarily help, but here's something I've experienced ...

    I have 4 identical backup USB drives (Freecom Mobile Drive) all bought at the same time, so likely/possibly to be from the same manufacturing batch, I use Acronis True Image to backup.

    First thing: Some of the drives won't work on a powered hub, some do. Not enough power despite supposedly having 500ma available. All work on the desktops I've tried plugged straight into the host USB sockets though.

    Secondly, one of the drives was very marginal on one laptop. Backup would sometimes fail with strange errors, sometimes the drive wouldn't even be seen. Suspect power problems. However, that later laptop developed a MB fault, so I put the HD into an identical spec spare and all of the drives work fine. Possible MB fault? Power levels?

    Third thing, on all machines (XP), I can happily remove the USB drive without problems once backups are finished. No need to 'safely remove' despite using write cache. Except on one desktop which invariably gives a 'data lost' error on unplugging. Which is odd, because that machine is identical to the one next to it which doesn't give the error. And no data has ever been lost.

    Conclusions? I hate hubs, powered or otherwise, identical USB drives behave differently, identical PCs USB ports behave differently.

    FWIW, I've never had an external USB HD fail. My oldest is a 60GB Freecom with external power supply that's used every day. I think I bought it in 2003, still going strong, if a little noisy.

    Like I said, not much help, but weird stuff does happen. Just don't ask me about DIMMs and certain MBs ... That one took me a year to resolve!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts