I'm having a strange problem on my Windows 7 64bit system with one particular USB hard drive. I have been using it for my backups on a regular basis for the past year and recently it started giving me problems.

When I connect it to the system, after a variable amount of time it will stop responding and generate a "The driver detected a controller error" error in the system log. After which I get a whole bunch of ntfs warnings of "The system failed to flush data to the transaction log. Corruption may occur." because it can no longer read or write to the ntfs drive.

This only seems to happen with this one drive, my other USB based devices are all working fine. I have tried different ports with the same result. If I plug the usb HD into another Windows 7 64bit machine, it works fine, will do a completed checkdisk /r to search the entire drive for bad sectors and comes up with no errors. So the drive works fine on another system.

Anyone seen this before? I even tried uninstalling all my USB drivers from Windows, deleting the infcache.1 USB driver cache and starting over, but that did not fix the problem either. The system is running cool and stable (both CPU and memory) so not sure what is going on.